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Creating a New Company

The multi-company versions of our applications store the databases and others files for each company in
discreet folders.  So, creating a new company simply means creating a folder for that company and copying
an empty database to it.

Each of our multi-company applications includes a “wizard” routine to simplify this procedure.

There are three steps to follow:

• First, create the folder to hold the database.
• Then create the database in that folder.
• Finally, import or create groups of records in the database, as needed by the application.

The following is a brief outline of how to do this.

Note: You may want to print this document for future reference.  Just select File>Print or click the
printer icon and print in the usual way.  See Appendices for more on this.
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Creating the Folder

The easiest way to do this is within “My Computer” (or Windows Explorer).

1.  Double-click on the “My Computer” icon on your desktop.  Or select Start>My Computer, or select
Start>All Programs>Windows Explorer.

2.  Select the drive on which you want to create the folder – usually “c:\” or “f:\” on a network server – by
double-clicking on it.

3.  (Optional) Select the folder in which you want to create the folder for the company data, such as “c:\Payroll
Data”, the folder named “Payroll Data” on the “c:\” drive.

4.  Select File>New>Folder.  Windows will create a new folder, with the name “New Folder” and that name
highlighted.

5.  Type a name for the folder – one that you will recognize as containing data for the new company – and press
Enter.

6.  Close “My Computer” (or Windows Explorer).
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Creating the Database

Note: Naturally enough, in order to create a new company, the multiple-company capability for the
application must be enabled.  If File>Company is not enabled, select Tools>Preferences, click the
plus sign next to “Application” to open it, and double-click “Enable Multiple Companies” do change
from “No” to “Yes”.  Click Apply to save this setting.

You create the database for the new company within the application.

1.  Launch the application in the usual way and select File>Company.

The application will show the “Open Company” dialog, the window from which you select companies.

2.  Select File>New (or press F3).

This will launch the “New Company” wizard, and you will see
an introductory window like this:

3.  Click Next or press Enter.

The next window prompts you for the folder in which you
want to save the new database:

4.  Click the [...] Browse button to select the folder you
created above under “Creating the Folder”.

If you did not use “My Computer” or Windows Explorer to
create the folder, you can point to where you want it, check
Create new subfolder, and type in the name.

(While this seems faster than using “My Computer”, we
recommend creating the target folder separately – in “My
Computer” or Windows Explorer – because that method offers
fewer opportunities for errors.
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5.  Click Next or press Enter.

In the next window you determine the source for the new
database you are about to create: either a new/empty one or a
copy of an existing one.

To start from scratch, leave the selection at New/Empty
Database.  If you have a template database or want to copy
the accounts and report formats from another one, click
Existing Database and select that database.

6.  Click Next or press Enter.

The next window prompts you for the name of the new
company.  This is the name you want to print at the top of all
reports.

Of course, you will be able to change this and add an address
and other information within the application later.

7.  Click Next or press Enter.

You are ready to create the new company.

8.  Check the location, database source, and company name.
 If they are correct, click Finish or press Enter.

(If there were a problem with something you had selected
earlier, this window would show you an alert and Finish
would not be enabled.

The wizard will create the new-company database (and the
folder if you chose that function at #4 above).
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9.  Click Close or press Enter to close the New-Company Wizard.

You will return to the “Open Company” dialog, and the new company will appear in the list.
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Creating Basic Records

After you have created the new database, you can select it from the “Open Company” dialog, and it’s ready
to go.  However, with some applications, there are some basic database records you will need, and it’s best to
deal with these right away.

The following is a brief description of some of these procedures.

Note: As with any procedure that makes wholesale changes to your database, you must backup your
database before proceeding with any of these steps..
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General Ledger

If you have another existing company with a Chart of Accounts that you want to use with the new one, you can
import those accounts into the new database.

You can also import the report formats from the existing company, if you want to use them for the new
company.  If you want to use the same Chart of Accounts but create new report formats from it, you can create
basic report formats for the Balance Sheet and Income Statement, and then modify them as you wish.

Finally, there are also a few basic settings you will want to review before you begin using the new database.

Note: As it starts, the import routine deletes all general-ledger records from the database!  If you
perform this procedure on a database with existing records, all of those will be lost.  You should
perform this procedure only on an empty database (such as one you just created) or one that you mean
to clear.

Here are some descriptions of these:

Importing a Chart of Accounts

1.  From the main General-Ledger window, select Tools>Utilities>Import.

The application will open the “Import General Ledger Data
Files” window:

2.  Click the [...]/Browse button and select the database from
which you want to import either the Chart of Accounts.

Note: From this window, you can not import report
formats without also importing a Chart of Accounts.
To import report formats after you have already
imported the accounts, see “Importing Report
Formats” below.

3.  Check Chart of Accounts.
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4.  (Optional) If you want to import all the reports from this existing company’s database, check Report
Formats.  You can also import specific report formats later (see “Importing Report Formats” below), and you
can create basic report formats directly from the new Chart of Accounts (see “Creating Basic Report Formats”
below).

5.  Click OK.

The application will import the Chart of Accounts (and all report formats, if you selected that).

It’s probably good procedure to immediately print a Chart of Accounts (Print>Chart of Accounts) and verify
them.

Importing Report Formats

You can select specific report formats from another database for an existing company.

Note:  Of course, the account assignments in the report format you import must match the accounts
in the database.  If, during the import routine, the application encounters an account that does not
exist in the database, it will not add the assignment record but will list the descriptions of these lines
at the end of the processing (see “Errors During Importing Report Formats” below).

1.  From the main menu, select Print>Report Formats>Edit.

2.  Select Tools>Import.

The application will open the “Import Report Format”
window:

3.  Click the [...]/Browse button in the “Source Database” box
and select the database from which you want to import the
report format.

4.  Click the [...]/Browse button next to the “Format” box to
select the report format to import from those in the source
database.

5.  Click OK to import the report format you selected into the database for that company.
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Errors During Importing Report Formats

If the import processing encounters any errors (such as an account assignment for an account not in the
database), you will see a prompt warning about this with an offer to print a log of the errors.  You should print
this log to see what happened.

Creating Basic Report Formats

When you are setting up a new company, another alternative to importing report formats from another company
is to build report formats from the existing Chart of Accounts.  Or, if you have simply entered the accounts,
one by one “from scratch”, this is a great way to create basic report formats for the Balance Sheet and Income
Statement that you can then edit without having to tediously key each line.

1.  From the main menu, select Print>Report Formats>Edit.

2.  Select File>New (or press F3).

The application will open a window like this:

3.  Select the report for which you want to create a format,
either a Balance Sheet or an Income Statement.

4.  Enter a description for the report format.

5.  Check Build from Chart of Accounts.

6.  Click Yes.

The procedure will build a report format with standard headings, one line for each account, and totals for each
group and all standard settings.  You can use this as a starting point – combining lines if you want, adding extra
spacing for readability, changing font sizes or faces to improve appearance, or any other changes that make
the report exactly as you want it.
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Basic Ledger Settings

Finally, after you create a new company, and whether you
import or create new accounts and/or report formats, you
should review the basic application settings.

From the main menu, select Tools>Settings.

The application will show a properties window like this:

Change the appropriate settings and click Apply.

Use the “Departments” tab to create the companies
departments.  Skip this for a non-departmental general ledger.

Select the “Reports” tab for settings related to fonts and
graphic properties for the Balance Sheet and Income
Statement.
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Payroll

Before adding employee information or doing any work with
the new database, there are several parts of the database that
need your attention.  You deal with these on the tabs of the
“Settings” window at Tools>Settings.

The following is a very brief list of these settings:

General

These are default settings for new employees and for the days
ending a pay week or bi-weekly period.

Deductions

Add a line for each payroll deduction (amounts deducted from
employee paychecks other than tax withholding).  Check the
appropriate column to control how Payroll calculates a given
deduction.

General Ledger

If you want ledger-account distributions for all the payroll
amounts, you will need to assign the appropriate account(s) to
each of the tabs, “General”, “Pay Types”, “Withholding”, and
“Deductions”.  If an account does not exist, click Accounts to
open the “Ledger Accounts & Departments” window to add them.

Reporting

If you want your reporting so show Workers’-Compensation and Unemployment amounts, you should enter
the appropriate values.

FICA/Medicare and Tax Tables

Before running your first payroll, you must be sure that the
system includes the current constants and tables.

Note: You can download the tables for the current
and past years from our web site at
http://minilogic.com/minilogic/updates.html .   There
is a link to instructions on that page.

http://minilogic.com/minilogic/updates.html
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Editing Company Names and Database Paths

When you create a new company (see above), you assign a company name and path to the folder holding the
database and other application files.  Generally, you will not need to change these, but you can if you like.

Changing a Company Name

To change a company name, select Tools>Settings and the “Company” tab from the Settings properties
window.  Edit the name, as you would any other data, and click Apply.  The application will also change the
company name as it appears on the “Open Company” dialog (at File>Companies).

Editing the Path to Company Data

1.  From the main General-Ledger window, select File>Companies to open the “Open Company” dialog.

2.  Point to the company for which you want to edit the database path and select Edit (or right-click your
mouse and select Edit Database Path).

3.  Click the [...]/Browse button next to the path you want to change and use standard Windows techniques
to choose the new path.

4.  Click Save to save these settings.

Note: While this routine performs rudimentary verification of the path you select, this change is a
permanent one, and you should be careful.  Again, this is not something you would normally need
to do.  Once you set a database path, you should never need to change it.
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Appendices

Saving This Document

If you haven’t already, you can save this document to your system, and it will be available from Help within
your application(s).

The folder to which you save this document depends on whether you use this application for more than one
company.  If you do, you will want to save it on this computer or local-area network (LAN) station, in the same
folder as this application.  If you use this application for only one company, you should save this in the same
folder as your database.

Here’s how:

1.  First, make a note of where you want to save it.

The easiest way is to click File>Settings and the “Application” tab.   If you use this application for more than
one company, write down the path next to App.Path.  Otherwise, make a note of your DatabasePath.

2.  Next, locate the disk icon in the Acrobat Reader toolbar (below the menu bar
at the top) and click it.

In some instances, you can also select Find>Save A Copy (or Save As or
something similar) from the menu bar.

3.  Now point to the folder you noted in #1 above.

Make sure you don’t change the name of the file from what appears at the top of this window (to the right of
“Acrobat Reader” in the window heading above).

4.  Click Save.

Now, when you launch your application, the appropriate Help option should be enabled, and clicking it will
bring up this document.

Printing This Document

Locate the printer icon in the Acrobat Reader toolbar (below the menu bar at the top).  Click it to
print all or part of this document.  You can select individual sections or pages.   You can print odd
and then even pages, for front and back, to save this for future reference.
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Navigating this Document

Here are some features of this PDF document format and the Adobe Acrobat Reader that make them especially
effective:

Table of Contents

You have probably already noted the expandable outline over at the left.  Use it to go directly to a major subject
or procedure.  Click the “+” or “–” boxes to expand a section of the contents.

Hypertext

Throughout this document there are hypertext links (like this).  Clicking on these takes you to another related
portion of the document, usually for more details about a particular feature.

To return to where you clicked the link, click the Previous View button in
the toolbar at the bottom or top of this window (depending on the version of
Acrobat Reader).

Searching

If you can’t find the specific topic in the Contents at the right of this document – or if you
just want to search for something more detailed – click the Search icon in the Acrobat
Reader toolbar.

Just type the key word(s) and press Enter.
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Document Updates

We generate new versions of these documents when we roll out new versions of the applications they describe
– and sometimes in between.

You can download the latest by selecting Help>Internet Support>Quick Start Guide from within the
application (the actual menu option may vary in some applications).

For general-purpose documentation, go to http://minilogic.com/minilogic/documentation.html.

MINILOGIC SYSTEMS and 4BYTE-PROJECTS provide this document as a supplemental service to their customers.

©Copyright 2000-2007 MINILOGIC SYSTEMS.
MINILOGIC SYSTEMS and 4BYTE PROJECTS reserve any and all rights to these materials whether expressed, implied, or not.  They prohibit
reproduction and/or any use, other than by our customers.
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