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Though virtually everything we do are �works in progress�, this document is especially so.  This
is a very preliminary draft with many sections still to be written.  Please keep this in mind as you
read.  If you have any specific questions, please call us.

!"#$%&'(#)%"

This document is a very general description of our custom software applications, more of an on-going
reference to support the instruction we have already given you on-site.  It is absolutely not a key-by-key
instruction manual.  Our purpose, here, is to give you a general outline -- basic concepts -- so you can form
your own routines.

This document assumes a basic working knowledge of Windows either from other applications or the
instructions we have given you in person in your office.  Also, we describe here some rudimentary concepts
that you may already know but about which we feel we can give a different perspective.

Another purpose of this document is to describe, in black and white, how some operations in our MSDOS
applications have migrated to Windows.
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Again, this is a reference material, not a cookbook instruction manual.  So, while you�re welcome to use this
any way that�s helpful, it will probably be most useful answering specific questions or providing reminders
of things we�ve discussed over the phone or in person.

� Note the Table of Contents at the left.  Click on the plus-sign checkboxes to expand a heading.  (Click
the minus-sign to close one.)  Click on a topic to go there.

� Locate the binocular Find icon in the Acrobat Reader toolbar (below the menu bar at the top).  Click
it to search through this document for any occurrences of something in which you�re interested.

123)",-#.)+-&%('/0"#-4%$-56"7)"0-8079:

If you haven�t already, you can save this document to your local or server hard drive, and it will be
available from Help>General Guidelines within your application(s).  Here�s how:

1. Locate the folder in which your application database resides.

The easiest way is to click File>Settings, the �Application� tab, and make a note of the �Database Path�.

2. Locate the disk icon in the Acrobat Reader toolbar (below the menu bar at the top) and click it.

In some instances, you can also select Find>Save As from the menu bar.

3. Point to the database path you noted in #1.  Make sure you don�t change the name of the file from
�Guidelines.pdf�

4. Click Save.

Now, when you launch your application(s), the Help>General Guidelines option should be enabled, and
clicking it will bring up this document.

;$)"#)",-#.)+-&%('/0"#

Locate the printer icon icon in the Acrobat Reader toolbar (below the menu bar at the top).  Click it to print
all or part of this document.  You can select individual sections or pages.
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Here are some basic definitions of some words and concepts we use both here and in our software
applications.  Please note the differences between these similar application functions:

,"- Creating a new record in the database, usually one referenced by other records, such as
a new order, invoice, or customer.

.++ Adding a line to a group or list, such as to an existing invoice or order.  Also adding a
record to the database (equivalent to New, above) when selected from an Open Dialog
showing a grid (see below).

/0"# Retrieving a database record through an �Open-Dialog� window � or, in a more general
sense, starting or launching something

1)$2" Deleting a group of records based on one or more criteria, such as invoices older than
some cutoff date.

3"456" Deleting a single record from the database which is referenced by one or more other
records.  You select the record you want to remove, and the application will search the
entire database for references to that record and not allow removal unless there are no
records referencing it.

7%#8"& Just that: canceling what you�re about to, such as canceling the selection of a database
record from an open-dialog window.  This normally brings you back to the point from
which you started, such as clicking Open to select the open-dialog window.

7&5(" Closing the current window (but leaving the application running).  Pressing [Esc] is the
same as selecting Close.

9:*; Closing the application and returning to the Windows desktop.

=$$%$+-2"&-+',,0+#)%"+

If you find any errors in this document or have any suggestions about it, we�d love for you to contact us.
Please just keep in mind that this can not be a detailed operational manual or include instructions unique to
specific applications.  However, your thoughts could be very helpful to everyone.

We appreciate any feedback you can give us.
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The key to using our software -- any software -- is developing your own routines.

For the most part, these are the steps normally involved in a session:

1. Launch the application.

2. Enter new data.

3. Print an Edit List and/or make changes.

4. Process

5. Print reports.

6. Back up*

7. Close the application

Users with MSDOS experience will be used to backing up after closing the application.  Our Windows
software incorporates options for backing up from within the application.  See �Backing up� below and in
the �Tools� section later in this document.

B2'"(.)",-2"-2997)(2#)%"

First concept for using Windows: Click to select; double-click to launch.

Pointing at something with the mouse arrow and clicking the left mouse button selects it.  This doesn�t mean
much from the Windows desktop, but within an application it�s the quickest way to choose what you want
to work with.

Doing the same thing but double-clicking starts or launches it.  To launch an application, move the mouse
arrow to the icon on the desktop and double-click the left button.  (Or, click Start to open the Windows
Start Menu, and move the mouse pointer through the options until it�s pointing to what you want, and click
it to select it from the menu, launching it.

*+)",-2"-2997)(2#)%"

There is a rhythm to entering, changing, and saving data in a Windows application.

Though Windows can display many windows on the screen at one time, only one of them is current for the
application.  That is the one with which you are working, and you need to keep that in mind.  Leaving that
window without saving your work may � or may not � give you the results you want.  So, the first thing to
get used to is:

1. Start a new window (either with new or retrieved information).

2. Add, change, or delete what you want.

3. Check you work.

4. Save it.
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Almost always, the window will have a Save button in the lower right.  Click it with the mouse, or move
control to it with Tab or Shift+Tab and press Enter, or press Alt+S (as indicated by the underlined �S�
on the button), or if there�s a menu at the top of the window, select File>Save.

C%'+0-%$-D0E-+#$%D0+

We -- and most of our long-term customers -- still favor keyboard entry as the fastest way to flow data into
an application.  In the Windows environment, however, the simple fact is that the mouse is an integral part
of the �interface�, and you�ll have the most success if you can learn to switch between typing on the
keyboard and clicking directly on the screen with the mouse to select a series of items or go directly to some
item to enter or change.

In an attempt to appeal to both approaches, we�ve tried to build in as many key-stroke-based selections as
possible.  Whenever you see an underlined letter on a button, menu option, or next to a field or control, you
can press Alt+X (where X is that letter) and move focus directly to that button, option, or field.

;$0++)",-D0E+-#%%-F')(D7E

The third step, checking what you�ve done, is very important.  If you�re used to working with MSDOS
applications, you know that you can type several keys ahead of what the computer can process, and the
application will simply catch up.  This procedure may not work in a Windows application!

Windows can �multi-task� and MSDOS could not.  This means one of the keys you press could start
Windows off doing something else at the same time it�s processing the rest of the keys you�ve pressed.

Let�s say you press [A], [B], [C], and [D] � one after the other and more quickly than the computer can
process the results.  Under MSDOS, the application could not respond to your having pressed [C] until it
had completed whatever was called for by your pressing [B].  Under Windows, the application will respond
to your having pressed [C] whether it has completed what was started by your having pressed [B] or not.
If the work done by your pressing [B] is necessary for [C], then the application will crash!

(Today�s computers are fast enough that most of the times when this multi-tasking situation becomes a
problem is when the application is fetching information from a database, especially over a network, such
as when you select a customer or inventory item -- or when it is opening or closing a window (and
populating it with data).  When you know you�re doing this, just pause for a second to give the application
time to do what it needs to, and you�ll be fine.)

As much as possible, we have tried to build buffers into our applications to handle these multi-tasking
situations.  But, these are custom programs, and they can�t have experienced the level of testing and use
of a nationally-sold application.  If you�re consistently having a problem, please let us know, and perhaps
there is a modification we can make to help.

However, the best approach is to develop that rhythm.  Learn when to pause and check what you�ve keyed
before you move on.  As part of the application flow, that pause can actually give you and the computer
time to stay on track � and save time on the whole.
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<405$;%#;=,5;"  We have discovered an... idiosyncrasy... with the Microsoft Visual Basic runtime
software.  Apparently (though we have not been able to document this), some time shortly after you
have launched the application and started saving data, the application will pause and do nothing for
several seconds.  You will be able to move the cursor, but the application will not respond to mouse
clicks or key strokes.

Our best guess is that the runtime software (the Windows internal programming that is driven by the
application) is reorganizing memory.  We�ve seen this happen in all Windows applications, though
the duration with a Visual Basic program seems longer.

We are researching this problem and will distribute updates when we have a resolution; but at this
time, our only advice is to be ready for the pause, be patient and wait the few seconds, and then
move on.  As we have seen it, this happens only once during a session with the application.  In other
words, once the memory has been allocated, it does not have to be again, unless you close and re-
launch the application.

G2(D)",-'9

Of all your normal routines, without exception, backing up is the most critically important.

In our Windows applications, we have included an option for backing up the entire database from within the
application.  All you do is select Tools>Backup and click OK and that�s it!  And, even with very large
databases over networks, on today�s equipment this backup routine takes only a few seconds.

There�s just no excuse for not making frequent backups part of your normal routine and backing up several
times a day.

For more specifics on backing up, please see �Backing up� in the �Tools� section below.

H7%+)",-2"-2997)(2#)%"

To close virtually any Windows application:

Select File>Exit, or

Click the close button (the button with an �X� in the upper right corner of the main application window, or

Click the icon in the upper-left corner of the main window and select Close, or 

Press Alt+F4.

Of course, closing an application completely shuts it down, usually without any checking of whether you�ve
completed all that you wanted to.  If you have made changes, the application will often not alert you to save
your work before closing.  Please make sure you have saved everything before closing the application.
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Most MSDOS applications used pressing Enter to �finish� a field or item on the screen.  You pressed Enter
from item to item, then used some other mechanism � such as pressing Esc � to �finish� with a screen and
save your work.

Windows is different, more like mainframe computer systems.  Press Tab to �finish� and move to the next
field or item.  (Press Shift+Tab to move �back� to a previous item.)

This is an important routine to adopt.  If you�re used to pressing Enter and continue doing that with a
Windows application � any Windows application � you�ll have an impossible time.  This is the most
common error made by MSDOS users moving to Windows.  Generally, you press Enter to �click� a button
to which you�ve moved with Tab.  That�s about the only time.

5K042'7#:-I'##%"+

There�s an exception to the above rule against pressing Enter.

Occasionally (though rarely), we will code one of the buttons on a window as the �default�, meaning
pressing Enter when you are on this window will be the same as clicking that button.  You can recognize
these because they will have a darker and deeper shadow than the other buttons.

This design mimics our MSDOS applications in some limited ways.  Examples are all Open Dialogs and
some windows with which you are adding new records to a database.

When you launch an Open Dialog, the control or focus will be on the grid of records.  You can press keys
to move the highlight to the record you want (as with our MSDOS applications) and press Enter to select
the default button which is Open.  (See �Selecting from an Open Dialog� below.)

If you are completing items on some windows prior to creating a new database record, we may have coded
it so you can fill in only a few items and press Enter to select OK as the default button from the bottom of
the window.

These examples may appear to be functionally the same as our MSDOS applications, but that�s coincidental.
It�s very important to remember that these uses of Enter are rare exceptions designed simply to help speed
up data entry and eliminate your reaching from the keyboard to the mouse.

L23),2#)",-#.$%',.-%'$-2997)(2#)%"+

{More to come.}
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The following is a general description of methods for keying and changing items (fields) on the screen.  For
the most part, entering new and changing existing are the same, and we don�t discriminate between the two.

Details beyond these general guidelines are specific to the specific circumstances or contexts.  If you have
a question at that level, please call us.

What follows won�t make much sense in the abstract.  The best way to get a handle on this is to take these
guidelines to the computer, launch the application, and find examples of each type of field.

H.2$2(#0$-4)07&+

Character fields are items that can be any character you can type from the keyboard.

There are two basic types of character fields: Ones you can type and ones that represent a database record
(such as a customer) and you select from a subsequent dialog box.

Note: Character fields can be both single- and multi-line.  To add a �hard return� to a multi-line character
field, press Ctrl+Enter.  Otherwise, just type, and the application will format the multi-line field to fit.

@)07&+-E%'-(2"-#E90

With most character fields, you can just move the cursor to them (with Tab, Shift+Tab, or the mouse) and
type what you want.

The cursor will be an I-bar showing you where you are typing.  You can locate the cursor with the arrow keys
or the mouse.  Just type what you want.  Backspace and insert work as in word processing (the Windows
default mode is insert).

Examples: Inventory and order descriptions; purchase order numbers; memos

@)07&+-E%'-+070(#

Pressing Tab (or Shift+Tab) will skip over fields you can not enter directly but must select from an Open
Dialog.  And, these will have a button immediately to the right or below (usually Browse) to which you will
go with Tab (or Shift+Tab).

When you click that button, or double-click on the field, the application will open a dialog box with a
scrolling grid of available selections.  (See �Selecting records from the database� below.)  For example,
clicking Browse next to a customer name will open a scrolling list of customers.  When you select one, its
name automatically goes into the field in the original window.

L%#0M  If there is no Browse button for a field which you select rather than type (such as for a field that
you rarely assign or change), double-click on the field with the mouse to assign or change it.  Sometimes
you can change fields in a status bar at the bottom of the field in this way.

K070#)",-2-4)07&-E%'-(2":#-#E90
Usually, you must have some selection in a field you select from a dialog box.  In some cases, you can
change from a previously selected value to �none of the above�.  To perform such a deletion, place the
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cursor on that field with the mouse and press Delete or Backspace.  (The application will ignore all other
key strokes.)

!/9%$#2"#-L%#0: When you select a record with a dialog box (the second type of character field), you�re
actually pointing to a record in your database, such as a customer.  Technically, the application does not save
the name or description after doing so, only the pointer to the chosen �master� record.  This makes it
impossible for you to chose one customer, for example, and then type in a name for another (obviously a
bookkeeping nightmare).

L'/0$)(-4)07&+

Almost always, the context will tell you whether a field is numeric.

As with standard character fields, just type in the value.  Leave off commas for thousands and dollar signs
for currency, but (of course) include decimal points where necessary.  The System will ignore any other keys.
However, some key stroke combinations, typographical errors, may give results other than what you expect.
For example, keying �1.02.03' will ignore everything after the second decimal; but if you meant to type
�1.03', you will have entered something else.

L%#0M Some numeric fields have Up and Down arrows at the right end to help incrementing and decrementing
the value by one.  Unfortunately, you have to use the mouse for this; the Up and Down keys do not work the
same way.  Thank Microsoft.

=N2/970: Copies (report printing)

?-"%#0-%"-$%'"&)",
Our applications almost always use �symmetric arithmetic rounding�.  This means (as an example)
applications always round fractional cents equal to or greater than $0.005 to whole cents. $1.234 remains
$1.23, but $1.235 becomes $1.24.  This is the same type of rounding as Microsoft uses as a default in
Excel®, but there are other kinds.  If you have any questions, please give us a call.

K2#0-4)07&+

Again, the context will make a date field obvious.

There are several ways to edit a date field.  Keep in mind that, while other fields consist of a single value,
a date field is made up of at least three internal parts, month, day, and year -- and, if the time is included,
the hours, minutes, and (sometimes) seconds.

When you first move to it, the System will highlight one internal part of the field, such as the month.  You
can increment (increase by one) that highlighted part by pressing Up or decrement (decrease by one) by
pressing Down. You can move the highlight right or left with the Right or Left keys.

L%#0M Date fields are �smart�, in that you can not enter an invalid number, such as the 31st of June, and if
you increment past the last or first days of a month, the System will adjust for the number of days in the
next or previous month.

Or, of course, you can just key the date values, pressing Right or Left to move to the next or previous part
of the date.
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If the format of the date field includes abbreviations, such as �Thu� for �Thursday� or �Sep� for
�September�, rather than numbers, you can still perform the same operations as if the values were numeric.
You can still increment and decrement with Up and Down, and you can still press numeric keys to enter
a specific value directly.  (For example, if the highlight is on �Sep� and you key �10", the System will
display the �10" you keyed until you move off that part of the date.  Then, it will show �Oct�.  If the
highlight is on �Thu� and you press Up, the day of the week will change to �Fri� and the rest of the date
field will change to reflect that Friday�s date!)

As with all fields, press Tab to �finish� and move to the next field (or Ctrl+Tab to move to the previous
field).

H270"&2$-3)0A

If you click on the button at the right end of a date field, the System will reveal a calendar view of the
month with a red circle on the field�s current value.  You can use the mouse to click on a different day, or
click on buttons to move forward or backward through the calendar -- or press Up, Down, PageUp, and/
PageDown to accomplish the same thing.  This is simply a more graphical way of communicating the same
information to the application.

;<"=>(&?%"@>%".(1"A-@>-&"@>%".-+B)(1%."C<&@>: move the shaded circle to the day with the direction keys
or the mouse.

;<"=>(&?%"@>%"C<&@>: press PgUp or PgDn or click one of the arrows at the top of the calendar or click
on the month at the top of the calendar and select from the list the pops up.

;<"=>(&?%"@>%"1%(': press Ctrl+PgUp or Ctrl+PgDn or click on the year at the top of the calendar and
click the up and down arrows to increment or decrement.

L%#0M Again, there are many ways to enter date fields.  The right one is the one that works best for you.
The only way to find that is to try the others and decide.

=N2/970: Order date; invoice date

B)+#-4)07&+

Sometimes you select one item from the contents of a �drop-down� list.

There are two kinds:

� Ones that allow you to enter text that�s not in the list, and

� Ones that do not; that is, you must select one of the items in the list.

The latter is, by far, the more common.

(Don�t confuse this type of field from character fields using a dialog box.  List fields are simply character
fields for which there is a relatively limited number of possibilities.)

Both types of list fields have a button at the right edge of the field.  Clicking on that button will open a list
of options.  You can select one by scrolling to it with the mouse.  Or, you can key one or more letters (the
System will move the highlight to a matching item) and press Tab to select it.

Without opening the list, you can perform the same keystroke-based selection, but the list from which you
are selecting will not automatically appear on the screen.  If the list field does not support your typing a
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L%#0  Unlike our open-dialog windows, the MICROSOFT run-time software does not support pressing
more than one key, such as pressing M and O to select �MO� (rather than, say, �MN�).  The control
responds to each key stroke independently.  So pressing M points to the first item in the list
beginning with �M� and pressing O moves to the first starting with �O�.

unique entry (again, the most common type), the System will immediately display the first matching item
and highlight it.  Pressing Tab to �finish� the entry will select that item.

If the list field does support your keying a unique entry, the System will point to a matching item in the list
but it will not show you the list.  If you just press Tab, Windows will accept your entry as a unique one (one
not in the list) and use it.  To see the match that the System found based on your keystrokes, press Down
(think: �Show me the list down there.�).  Doing that will put the found item in the field as if you had typed
it entirely.  Press Tab to select it, or scroll to select another.

In both cases, you can manually open the list by pressing Alt+Down.

And, in both cases, you can scroll through the list options by pressing Up and/or Down, and Tab always
selects what�s in the field.

H.0(DI%N0+

Checkboxes are obvious; they consist of a description with a box to the right or left.  Generally, these fields
are �Yes/No� values, describing whether something is true or false, whether you want the system to do
something or not.

Clicking on the box or pressing the Spacebar with the focus on that field selects that option; doing the same
thing again deselects the option.

If the prompt for the checkbox has an underlined letter, pressing Alt and that character will act exactly like
clicking the checkbox with the mouse.

O2&)%-I'##%"+

Radio buttons are just like Checkboxes, except they are round (instead of square) and they are always grouped
with other related radio buttons.

Clicking a checkbox selects that option, without any relation to the rest of the items in the window.  Clicking
a radio button selects that option, and deselects any previously selected option in that group.  You can select
only one of the radio buttons from that group.

Again, if the prompt for the radio button has an underlined letter, pressing Alt and that character will act
exactly like clicking the circle with the mouse.

(These fields get their name from the �pre-select� buttons on a car radio.  When you press one, it selects that
station.)

=N2/970: �Printer� or �Combined PDF file� on a Print Dialog.
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In a couple of instances, you will encounter a list of options, within what appears to be a multi-line character
field, that have the appearance of a file directory tree � like an outline with major headings, possibly minor
headers, and then details within each heading.  Usually, these will also have Checkboxes at the left to allow
you to select a line.

These fields are nothing more than multi-line Checkboxes allowing you to select all, none, or some of the
Checkboxes, with a logical hierarchy to the items in the list.

Clicking on a heading checkbox will select all details in its group.  Clicking again will deselect all.  When
all items are selected within a group, the heading line will appear in boldface.  So, if a heading line is
checked but not in boldface, only some of the detail items have been selected.

To �explode� or open the detail lines of a heading, double-click the heading description (not the checkbox).
If you then click (select) detail lines, the heading checkbox and description will reflect your selections
(showing a check or not, or displaying in boldface if you have selected all the detail items).

If an item is a heading only and had no details for you to check, it will be disabled (�nothing to select�) and
appear grey.

L%#0! Here, we say �clicking� an option, meaning clicking with the left mouse button.  You can also move
the highlight to an item and press the Spacebar, as with regular Checkboxes.

=N2/970: Most Processing Dialogs (from File>Process)

K)+2I70&-4)07&+

There are often circumstances in which you can not enter or change a value, such as after the application
has processed it.  Usually, in these cases, the application will disable these fields, displaying them with gray
type on white backgrounds or with backgrounds the same color as the window itself.

You can not change disabled fields.  Pressing Tab or Shift+Tab will skip over them.

19$02&+.00#P7)D0-,$)&+

In most of our applications, there are two places in which you will see information displayed in grids of
rows and columns.  One type is the �Open Dialog�.  These are windows that usually open in response to
your clicking Open or File>Open or the equivalent, and their purpose is to help you select records from
a database, such as customers, inventory items, and so on.  (See �Selecting records from the database�
below.)

The other type of grid is the data-edit grid.  These are simply collections of data, within a data-edit window,
in which everything is arranged in rows and columns very much like a spreadsheet.

These grids normally occur within a larger context of editable data.  In other words, there are probably
several items of data on the screen, and some of them are arranged in rows and columns like a spreadsheet.
You work with cells in these grids, so the cell will be highlighted � with a gray border.  (In some contexts,
you select rows from these grids, but these situations are obvious, and the highlight is a different color from
an Open Dialog.
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There�s a very important concept here:

In windows without one of these data-edit grids, there will be two layers: the window itself and the
individual fields or controls within the window.  The window opens; you move from field to field (control
to control); and you finish with the window by saving your work and selecting another set of data or closing
the application

Windows with a data-edit grid have three layers.  Though it has many items arranged in rows and columns,
the data-edit grid is like a single field or control to the whole window.  When you press Tab from the field
immediately before the data-edit grid, focus moves to the current cell of the grid.  Press Tab again, and
focus move to the field immediately after the grid.

The individual cells within the data-edit grid are the third layer.  Once you have moved focus to the grid
(by pressing Tab or clicking on the grid with the mouse), you move within the grid with the Up, Down,
Left, and Right keys.  Again, you Tab (or Shift+Tab) to and from the grid; you move within the grid with
the direction keys.

Finally, this third layer is also evident when you edit the contents of a grid.  Once you start entering or
editing a cell (see �Editing a cell� below), the focus goes to that one cell, as if the grid were now just a
single field or control.  You edit that one cell just as you would any other field (see above), pressing Tab
(or Esc) to �finish� (or �cancel�).  After you have edited that one cell, the focus returns to the grid just as
before.  Move through the grid with the directions keys; move to the next field on the window with Tab.

(This sounds a lot more complicated here than it is.  Just think of the grid as a single field that you �step
into� to edit.  When you�re familiar with the three layers, it will all make sense.)

=&)#)",-2-(077

To add new information to a cell, just start typing.

To change the information already in the cell, double-click with the mouse or press [F2].

As with any data field, press Tab to finish.  If the cell is neither a date nor multiline text, you can use the
Up and/or Down keys to leave the cell.  (The Up and Down buttons have special functions for dates and
multiline text.)  Naturally, pressing Left and Right move the cursor within the cell.

To cancel the editing process, press Esc.  (Cancelling editing will return the value in the cell to what it was
before you began editing.)

B)/)#)",-&)+972E0&-&2#2

For speed and efficiency, you will often not want to have a grid (either type) display all available data.  In
such cases, the Open Dialog or data-entry/edit window will have a status bar across the bottom of the
window showing you what is included in the grid above.

The concept here is that showing all the records in the database would be unwieldy.  So, you click a button
or enter a value to limit what the application is showing you.

The criteria the application uses to limit the displayed data are different for different contexts.  To change
the criteria, sometimes you can click a radio button, sometimes a Browse or other button (to select a
�master� record), and other times you can double-click one of the boxes in the status bar at the bottom of
the window to select a criterion, such as the starting or ending date to change a date range, or even a
customer or other name to select one of those.  (Date ranges are inclusive; they include both starting and
ending dates.)
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Note: At present, you can not sort the rows of a data-edit grid as you can those in an open-dialog window
by clicking the column heading.  The only sorting you can perform will be from an option in the Edit menu,
such as Edit>Sort by xxxx.

O0+)Q)",

Most windows with spreadsheet-like data-edit grids (and most open dialogs) support resizing; that is, you
can drag the corners of the window to make it larger and the controls within will also enlarge.  You can also
change the column widths of the grid by placing the mouse pointer in the column heading and dragging the
border one way or the other.
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There are exceptions, but -- almost exclusively -- you select database records from scrolling lists in windows
that open when you click Open or select File>Open or the equivilent.  These are �Open Dialogs�.

You will quickly recognize these windows by their context (they �pop up� when you are selecting a record)
and the Open, Add, Cancel and other buttons at their top.  You select rows from these grids, so the row
will normally be highlighted.

690"-K)27%,+

In our custom Windows applications, Open Dialogs function very much like the �list/select� windows from
our MSDOS systems.

Select records by pointing the highlight to the one you want and double-clicking with the mouse or pressing
Enter or clicking Open.

Note:  Due to an idiosyncracy of the Microsoft DataGrid control, you will sometimes get a strange display
if you point to or double-click on a part of a cell outside the displayed text.  Any unusual displays are just that
and have no affect on function.  However, you may want to try to get in the habit of pointing to the text rather
than just the cell.

Important  Remember, pressing Enter in a Windows application is different from doing
the same thing under MSDOS.  Pressing Enter selects the default button on the window.
We have designed these applications so that Open is always the default button of an Open
Dialog.  So, pressing Enter is exactly the same as clicking Open.

� Press an alphabetic (or numeric) key to move the highlight to the first row starting with that letter.

Press [A] and the highlight will go to the first row starting with �A�.  Press another key and the highlight
will move to the first row starting with the combination of the two keys (such as �Ab� if you press [A] and
[b]).  Note that this �search� routine is case-sensitive, and lower-case letters precede upper-case ones.
Keying �AB� will give different results than  �Ab�.

Press Backspace to delete the last key you typed.  Keying �Ab� will move the highlight to the record
starting with those letters.  Pressing Backspace will move the highlight back to the first �A� record.

� Press Up and/or Down to move the highlight up and/or down by row.  Press PageUp and/or PageDown
to move up and/or down through visible groups of rows.

� Use the mouse to point to a row, or use the scroll bar on the right side of the grid to scroll the rows.

� Press Esc or click Cancel to close the Open Dialog and abort the selection process.

In some contexts, you can add a new record to the database by clicking Add.
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When you first launch an Open Dialog window, one of the grid�s column headings will be in all-capital
letters.  This is the column in which the application has sorted the data.  When you move the mouse pointer
over grid�s column heads, the pointer should change to a downward-pointing arrow.  (If the pointer does not
change, that grid does not support changing the grid�s sort order.)

Simply click on a different column head to sort the data based on that column.  The first click sorts the data
in ascending order (from �A� to �Z�); clicking again sorts in descending order (from �Z� to �A�) and puts a
(D) in the column-head description.

When you press keys to move the highlight within the grid, the application locates the highlight based on the
data in the sorted column.

O0+)Q)",

Most Open-Dialog windows support resizing.  If you point to one of the window borders, hold down the left
mouse button, and drag, you can make the window as large as you like, and the grid will enlarge to fit the
size of the window � showing more rows and columns of data.

Most Open-Dialog grids (and most data-edit grids for that matter) support resizing the columns.  Move the
mouse pointer to the heading at the edge or border between two columns.  Press and hold the left mouse
button and you can �drag� the column border to the right or left, making one column larger and the other
smaller.

In most cases, resized grids and windows return to their �default� or original sizes when you close and reselect
them.
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Most of our applications have another way to find records in the database: the menu option at Tools>Find.

1. Click on Tools>Find to open a window very much like Windows Start>Find>Files or Folders
option.

The application will open a Find window
similar to this:

2. Select the criteria for your search:

�Look in� -- the kind of records you want to
find;

�For� -- the field within the records you want
to use as a basis for the search; and

�Containing� -- the substring for which you want to search.

3. Click Find Now to start the search.

Click Cancel or press Esc to abort the search.

The application will open a window similar to
this: 

Note that the matches for the search string are
in all-capital letters between brackets.

L%#0M This operation uses sub-string searches;
that is, it locates any occurrences within the field
at �For�, whether they occur in the beginning,
middle, or end of the field. 

4. Move the highlight to the record you want and
click Open to select it.

L%#0M Many applications will support your selecting the Find Window from within an open dialog.  Press
Ctrl+F to open the Find window.  Of course, the �Look in� options will be limited to the records you were
selecting in the open dialog.  After you select a record from the Find Window, the application will return
you to the open dialog highlighting the record you selected.  Just press Enter or click Open to select it.
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We have developed a common report generator for virtually all of our printing.

When you select a report, you will almost always see a window very close to this:

Here are the parts of such a typical report window:

D%'+-<& The format or version of the report.  For example, does it include transactions and
subtotals, transactions only, or subtotals only

E&=),.% The portion of the database to be included, such as all transactions or just those of a
certain type

F%G,%&=% The sequence in which the data are to be sorted

For The specific records to be included in the report.  This can be �all� records, a range of
records, or even certain non-sequential records.

� To change any of the first three, select from the drop-down list.
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To change the �For� settings, click Select.  The application will open a window similar to the following:

This window will have one row for each field listed in the �For� section of the report window.  The first
column is the name of the field, the second and third the values defining the ranges of each to be included.

L%#0M All of these selections use AND logic; that is, for a record to be included it must meet all of these
criteria.

The grid is a standard data-edit grid, and you choose or enter items in the same ways.  (See �Spreadsheet-
like grids� above.)  To change one or more of the criteria, move the focus to that row and column and press
F2 or press a key or double-click on that cell.

� If you select a single item, the assumption will be that you want to print for that one selection only.

� To select a range, select one under �From� and another under �Though�.  (If the line
is showing just one selection, still click under �Through�, and the application will
prompt for that second item.)

� If you are selecting from an open dialog, there will be a column of shaded blocks on
the far left with a wedge-arrow pointing at the current record, something like this---->

You can select more than one item by clicking on one, then holding down Ctrl and
clicking on others, and finally clicking Open.

� To apply your selections, click Apply.  Note that the text next to �For� on the report
window will show the ranges and items you have selected.

� If, at any time, you want to start over, just click Cancel and re-click Select.

H.%%+)",-2-9$)"#0$

{More to come.}
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For the most part, processing procedures are very different from one application to another and beyond the
scope of this very general documentation.  However, here are some generalities:

Definition: Processing means running a batch (collection) of database records through programming
routines to convert the information from one state to another and, usually, to create additional database
records as a by-product.

For example, most invoicing application will receive the data you enter, print invoices from them, then
process the information from printed invoices into sales history and accounts-receivable databases.  Usually,
this will mean selecting File>Process, and the application will display a window similar to this:

{More to come.}
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The Tools menu varies with each application.  Mostly it is a collection of utilities for performing basic
housekeeping and other database-wide operations.

Clearly, the most important of these is backing up.  Correcting entry errors is one thing; having to redo
several hours -- or even a day�s -- work is almost always a catastrophe.  So, don�t!  You can�t afford for
the time between backups to be any longer than the amount of work you can afford to redo.

G2(D)",-'9

Backing up is like making a photocopy of all your files and setting it aside for reference should something
happen to your originals (caused by a hardware malfunction, data corruption, or some other catastrophe).

<405$;%#; Maintaining a current backup is your responsibility!  There are several ways to do this; some
only taking a few seconds.  But -- without exception -- the most common reason for �losing� data is not
having a recent or good backup copy.  You simply can�t afford to use your computer unless you make the
time to backup and regularly!

G2(D'9-/0&)2

We have provided three ways of backing up your software on your system (and a fourth for backing up
servers on networks).  Which one you use depends on the level of protection you want and the time you
have for making the backup.

Quick Backup -- Our custom applications include a Backup option on the �Tools� menu that creates a
duplicate of the application�s database.  This is your quickest and least secure method of backing up.

Local Backup -- All of our 32-bit Windows machines include ZIP® drives for making removable-disk
backups at that machine.  You can use the IOMEGA® software to back up your application database.  This
is our recommended method for backing up.  You can use the same media for backing up networked
database (though it�s not practical to backup an entire network disk to removable-disk media).

Full-Disk Backup -- 32-bit Windows applications store information about each application throughout the
operating system.  The only way to make sure you have copies of all the information is to perform a
complete backup of the entire drive.  This may take up to four or five disks and up to an hour.  So, though
you may not want to perform a full-disk backup frequently, you must do so occasionally.  We recommend
once a month as a reasonable minimum.

Network Server Backup -- The only way to protect your network server is to make a complete backup of
its drive(s).  Our servers include high-capacity high-speed tape drives for this.  While tape is not a quick
backup medium (actually slower than removable disks), you can perform the backup unattended.  So, you
should make backing up your network server part of your routine, probably daily, certainly not less
frequently than once every couple of days.

The following section is a more in-depth review of these methods for backing up.
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As its name implies, the Quick Backup option we include in our applications is the fastest � though not
necessarily the most secure � method for backing up the application�s database.

You can make a Quick Backup -- copy the application�s database -- to the same location (drive and folder)
or to another drive and/or folder.  The former will work well if you�re not concerned about a hardware
malfunction, or on a network where you want the backup copy to be easily available to everyone using the
application.  Otherwise, choosing another location is probably a better idea.  Choosing another drive,
especially a removable one such as your ZIP® drive, is the most secure backup, since that will give you a
copy you can take to another machine, even another location.

In all cases, you should probably make a note of the target location for future reference.  If you check Save
This Target Path, the application will save the location and display it when you next select the Quick
Backup option.  But, it�s still a wise precaution to make a note.

C2D)",-2-R')(D-G2(D'9

1. From the application menu, select Tools>Backup

The application will open a window similar to this:

2. Click Browse to set or change the target path (optional).

The first time you perform a quick backup, you should make sure the path displayed next to
�Target:� is what you want (see above).

L%#0M Though the Backup window displays the backup file name (the application name
with the letters �BAK�), and it might seem that you can change this file name, you can�t.
For your protection, the Quick Backup routine forces its backup file name.  You can use
Windows Explorer to change the name of the backup file after performing the backup, but
we strongly recommend against this.

3. Check Save This Target Path (optional).

Again, do this the first time you perform a Quick Backup.

4. Check Close Application When Complete (optional).
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If you are finished working with the application and are performing a Quick Backup as part of that,
clicking here will close the application when the Quick Backup is complete.

5. Click OK.

The application will perform the Quick Backup and prompt you when it�s finished.

6. Click Close (if you did not click Close Application When Complete) at #4.
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Because Windows files are so large, the only practical way to make a local backup to a removable disk is
with high-capacity (�supper floppy�) disks.  We include IOMEGA ZIP drives and the latest IOMEGA backup
software with all our 32-bit Windows machines for this purpose.

L%#0M The easiest way to make a local backup of an application database is to use the application�s Quick
Backup option and point directly to a removable ZIP disk.  However, if you need to span several disks or
compress the data, you�ll need to use the backup software provided by the drive manufacturer.

C2D)",-2-7%(27-I2(D'9-#%-2-S!;-&$)30-'+)",-!6C=>?-I2(D'9-+%4#A2$0

1. Make sure all other applications are closed.

2. Click the IOMEGA Backup icon on the desktop.

The software will display a window much like this:
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{More to come.}



/%0',('1"234"!556 $%&%'()"*+%'"$,-.%)-&%+ � 27

G2(D)",-'9-2-"0#A%$D-+0$30$

{More to come.}
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Restoring frm a previous backup is not something to take lightly.  Remember, you are turning back the
clock for the entire database to the time at which you made the backup.  Any and all work you have done
since then will no longer exist!

Normally the only justification for resorting to a backup is corruption of the database due to a power loss
or hardware malfunction.

!/9%$#2"#-"0#A%$D-"%#0M If the application is networked (stores the database on a server that shares it
with other computers), you must have no other instances of the application running anywhere on the
network while you are restoring the database.  Attempting to access the database from one network station
while it is being restored from another can cause corruption of the database!

O0+#%$)",-4$%/-2-9$03)%'+-R')(D-G2(D'9

1. Select Tools>Backup from the application menu.

2. Click the Restore tab.

The application will display a window much like this:

Normally, the path and file name at �Source:� will be that of your last Quick Backup.  If it is, go
to #4.  If it isn�t, you must point to the source from which you want to restore.

3. Click Browse and point to the folder and file name of your most recent Quick Backup or the one
from which you want to restore.

4. Click OK.

The application will restore the database.

When it�s finished, the application will prompt you to restart, to reinitialize with the new database.
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Modern databases consist of data objects (what used to be called files and  fields) arrayed in complex
relationships (such as customers to their invoices, balances, addresses, and so on) -- all stored in a single
file on your computer.  The applications maintain these structures on the fly, as you add, change, or delete
them, including the tracking of simultaneous access over a network.  This process is fully as complicated
as it sounds!

Inevitably, as the application does its work, blank space and inefficiencies are added to the database.  From
time to time, you need to process the database to remove this �garbage�.  (In older systems, this procedure
used to be called reorganizing, or packing, or even �garbage collection�.)  Now, it�s called compacting.

How often you need to compact your database depends on the level of editing you perform.  Usually daily
is the least frequently.  Most users find making compacting the database part of the �end-of-the-day routines�
-- along with backing up -- the most convenient way to build it into their routines.  Customers who use their
database constantly throughout the day will need to compact more often, perhaps two, three, or more times
a day.

H%/92(#)",-E%'$-&2#2I2+0

1. Select Tools>Compact Database from the application menu.

2. Click Yes to proceed.

The application will make its own internal backup and then perform all the work necessary to make
the database work more efficiently.  It will display a prompt when it finishes.

!/9%$#2"#-"0#A%$D-"%#0M A networked database must be offline to the network while
the compacting routine is running.  The Network Administrator must notify all users to
not use the application (or other applications using the same database!) while this is
running.  This is a good reason for compacting the database just before bringing the
network down for the night.  Failure to limit access to the database while compacting may
cause corruption of the database!

L%#0M In addition to compressing and rebuilding the data structures, compacting also
recreates the various indices correlating the data.  So, even if you have not changed the
database since your last compacting, if you are having problems accessing data you know
to exist, try compacting the database.  It can�t hurt!

8%A-%4#0"-+.%'7&-E%'-(%/92(#T

This depends on the kind of work you do routinely.  Editing (changing) data adds very little inefficiency
to the database; adding and deleting records do.  So, you�ll want to organize both your work and
compacting around these types of routines.

As much as possible and practical, add new records and delete existing ones at a particular time -- and
compact the database right away.
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Minimally, you should compact your database at the end of the work day, perhaps as part of your backup
routine -- and in the middle of the day if your volume of new records is great.

!/9%$#2"#M On networked systems, the database is off-line (unavailable to all other
stations) during compacting.  You must announce that you are compacting so that other
stations do not attempt accessing.

O0+#%$)",-4$%/-#.0-(%/92(#P&2#2I2+0-I2(D'9

If you lose power during compacting -- or if the backup automatically made during compacting is your most
recent or best backup -- you can restore from it as easily as you can from a Quick Backup.

First, you�ll need to know the location of the application database.  You can find this by selecting
File>Settings>Application (in some systems, ...>System or ...>Current).  Note the complete path next
to �Database Path�.

Next, select Tools>Backup from your application menu and click the Restore tab.  Click Browse and
point to the folder/path you noted above and the file corresponding to �xxxCOPY.mdb�, where �xxx� is the
name of your application, such as �OrderKeyCOPY.mdb� for our OrderKey order-processing or
�InvoicingCOPY.mdb� for an invoicing application or �LedgerKeyCOPY.mdb� for our financial-accounting
applications.

Finally, just click OK.

After completing the restore, the application will prompt you to restart, to reinitialize with the restored
database.

Also see �Restoring from a previous Quick Backup� above.

K070#)",-#.0-(%/92(#P&2#2I2+0-I2(D'9

Each time you compact the database, the application will replace the automatic backup with a new version.
So, for the most part, there�s little good reason to worry about that file staying in your system.  Look at it
as an extra backup!

However, if you need to delete that automatic backup (perhaps to save space on a removable-disk backup),
select Tools>Backup, click the Restore tab, and click Delete Compact-Database Backup.  (If your
compact-database backup has already been deleted, that button will be disabled.)



/%0',('1"234"!556 $%&%'()"*+%'"$,-.%)-&%+ � 31

;'$,)",

{More to come.}
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{More to come.}
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